Как сделать бэкап микротик через winbox
Перейти к содержимому

Как сделать бэкап микротик через winbox

  • автор:

Как сохранить, восстановить и перенести настройки MikroTik

Операционная система RouterOS позволяет сохранить настройки MikroTik, и быстро восстановить резервную копию, чтобы возобновить работу устройства. Это очень удобно, если вы напортачили с настройками, или вам нужно выполнить одинаковую настройку нескольких устройств MikroTik. В этой статье мы расскажем, как создать резервную копию настроек MikroTik, восстановить ее или перенести на другое устройство.

Сохранение и восстановление настроек MikroTik

Чтобы сохранить настройки MikroTik, выполните следующее:

  1. Откройте в программе Winbox меню Files.
  2. Нажмите кнопку Backup.
  3. Во всплывающем окне нажмите кнопку Backup.
    При желании можете указать в поле Name имя файла и пароль в поле Password.
    По умолчанию файлы бэкапов шифруются, чтобы злоумышленники не смогли извлечь из них пароли, например, к Wi-Fi. Галочка Don’t encrypt позволяет отключить шифрование файла с резервными настройками.

Сохранить настройки MikroTik

После этого в списке появится файл с именем MikroTik-xxxxxxxx-xxxx.backup , где ххххххxx-хххх — это дата и время создания файла.

Файл с бэкапом настроек MikroTik

Внимание! Файл MikroTik-xxxxxxxx-xxxx.backup предназначен для восстановления настроек только на устройстве, на котором он создан. Его нельзя использовать для переноса настроек на другое устройство. Иначе у вас перенесутся MAC-адреса интерфейсов, в сети будут два одинаковых устройства и возникнет конфликт.
Для переноса настроек используются специальные файлы в текстовом формате, описанные ниже в разделе Перенос настроек MikroTik на другое устройство.

Далее резервную копию конфигурации MikroTik можно сохранить на компьютер, перетащив файл на рабочий стол или в проводник Windows.

Сохранить настройки MikroTik на компьютер

Перед восстановлением настроек, нужно сбросить все настройки устройства, чтобы в нем не остались какие-то настройки из текущей конфигурации.

  1. Откройте меню System — Reset Configuration.
  2. Поставьте галочку No Default Configuration.
  3. Нажмите кнопку Reset Configuration.
  4. В всплывающем окне нажмите Yes для сброса настроек и перезагрузки устройства.

Сброс настроек MikroTik

После перезагрузки подключайтесь к устройству по MAC адресу, поскольку IP адрес будет отсутствовать. В программе Winbox нужно нажать мышкой на MAC-адрес устройства и нажать кнопку Connect.

Чтобы восстановить конфигурацию MikroTik, выполните следующее:

  1. Откройте меню Files.
  2. Выберите файл с резервной копией.
  3. Нажмите кнопку Restore.
  4. В появившемся окне нажмите кнопку Restore.
    Если вы делали бэкап с паролем, то введите пароль в поле Password.
  5. В всплывающем окне нажмите Yes для восстановления конфигурации и перезагрузки устройства.

Восстановить настройки MikroTik

Перенос настроек MikroTik на другое устройство

Для переноса настроек на другое устройство MikroTik, нужно сохранить настройки в файл в текстовом виде. Этот файл можно будет редактировать, если возникнут проблемы при переносе настроек.

Переносить настройки можно только на устройства MikroTik со схожей аппаратной конфигурацией. Вы не сможете перенести настройки с роутера на 10 LAN портов, на роутер с 5-ю LAN портами. При этом будут выдаваться ошибки. Можно конечно вручную отредактировать файл с настройками, но это довольно сложный и долгий процесс.

Чтобы сохранить настройки MikroTik в текстовом формате, откройте меню New Terminal и выполните следующую команду:

export file=config_backup_20170403.rsc

Название файла может быть любым. В названии файла желательно указывать дату, чтобы потом не запутаться. В данном случае в названии файла указана дата 20170403 — 3 апреля 2017 года. Файлы с датой, указанной таким образом, будет очень удобно сортировать по имени в проводнике или в файловом менеджере Total Commander, FAR Manager или MC (Linux).

Далее нужно скопировать созданный файл в другое устройство. Для этого сначала перетащите файл на рабочий стол Windows. После этого перетащите его в новое устройство в меню Files.

Перед импортированием настроек, нужно сбросить конфигурацию устройства, иначе будет конфликт с текущими настройками и при импорте будут выдаваться ошибки.

  1. Откройте меню System — Reset Configuration.
  2. Поставьте галочку No Default Configuration.
  3. Нажмите кнопку Reset Configuration.
  4. В всплывающем окне нажмите Yes для сброса настроек и перезагрузки устройства.

Сброс настроек MikroTik

Чтобы импортировать настройки MikroTik, откройте меню New Terminal и выполните следующую команду:

import file=config_backup_20170403.rsc

При переносе настроек между похожими роутерами MikroTik с одинаковым количеством портов, но с разными процессорами или памятью, во время импорта могут возникать ошибки. Я как-то пытался перенести настройки между двумя очень схожими роутерами. При этом выдавало ошибку, что указанная частота памяти не поддерживается устройством. В этом случае откройте файл с настройками на компьютере, отредактируйте необходимую настройку или удалите ее.

Частичный перенос настроек

Бывают ситуации, когда нужно сохранить часть настроек, например, правила фаервола, скрипты, NAT, правила маркировки пакетов и т.п. Для этого помогут следующие команды:

ip address export file=ip.rsc
ip firewall mangle export file=mangle.rsc
ip firewall nat export file=nat.rsc
ip firewall filter export file=filter.rsc
queue simple export file=simple.rsc
ip dns export file=dns.rsc
system script export file=script.rsc
system scheduler export file=scheduler.rsc
tool e-mail export file=email.rsc
ip firewall address-list export file=address-list.rsc
ip route export file=route.rsc
ip dhcp-server network export file=network.rsc
queue type export file=type.rsc
queue tree export file=tree.rsc
queue simple export file=simple.rsc
interface ethernet export file=ethernet.rsc
ip pool export file=pool.rsc
ppp profile export file=profile.rsc
system logging export file=log.rsc

Автоматическое создание резервных настроек MikroTik и отправка на email

Чтобы не забывать делать резервные копии конфигурации MikroTik, вы можете автоматизировать этот процесс и отправлять бэкапы себе на email.

Создание скрипта

Откройте меню System — Scripts и нажмите «красный плюсик», чтобы добавить новый скрипт. В поле Name укажите название скрипта, в поле Source вставьте скрипт и нажмите кнопку OK.

Не забудьте в скрипте изменить значения [email protected] и your_gmail_password на свои.

Скрипт создания резервной копии настроек MikroTik и отправки на email

Чтобы протестировать работу скрипта, нажмите кнопку Run Script, и на ваш почтовый ящик будут высланы резервные копии. Процесс выполнения скрипта можно отслеживать в меню Log.

Скрипт для отправки резервной копии настроек MikroTik на email:

Для RouterOS v6.x

<
:log info «Starting Backup Script. «;
:local sysname [/system identity get name];
:local sysver [/system package get system version];
:log info «Flushing DNS cache. «;
/ip dns cache flush;
:delay 2;
:log info «Deleting last Backups. «;
:foreach i in=[/file find] do=»$sysname-backup-«]]!=»nil») do=>;
:delay 2;
:local smtpserv [:resolve «smtp.gmail.com«];
:local Eaccount «[email protected]«;
:local pass «your_gmail_password«;
:local backupfile («$sysname-backup-» . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . «.backup»);
:log info «Creating new Full Backup file. «;
/system backup save name=$backupfile;
:delay 2;
:log info «Sending Full Backup file via E-mail. «;
/tool e-mail send from=»» to=$Eaccount server=$smtpserv \
port=587 user=$Eaccount password=$pass start-tls=yes file=$backupfile \
subject=(«$sysname Full Backup (» . [/system clock get date] . «)») \
body=(«$sysname full Backup file see in attachment.\nRouterOS version: \
$sysver\nTime and Date stamp: » . [/system clock get time] . » » . \
[/system clock get date]);
:delay 5;
:local exportfile («$sysname-backup-» . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . «.rsc»);
:log info «Creating new Setup Script file. «;
/export verbose file=$exportfile;
:delay 2;
:log info «Sending Setup Script file via E-mail. «;
/tool e-mail send from=»» to=$Eaccount server=$smtpserv \
port=587 user=$Eaccount password=$pass start-tls=yes file=$exportfile \
subject=(«$sysname Setup Script Backup (» . [/system clock get date] . \
«)») body=(«$sysname Setup Script file see in attachment.\nRouterOS \
version: $sysver\nTime and Date stamp: » . [/system clock get time] . » \
» . [/system clock get date]);
:delay 5;
:log info «All System Backups emailed successfully.\nBackuping completed.»;
>

В примере указан скрипт для сервиса Gmail. При отправке через Gmail нужно предварительно разрешить ненадежным приложениям доступ к аккаунту. Для этого залогиньтесь, на странице «Мой аккаунт» перейдите в раздел «Ненадежные приложения» и выберите «Включить». Подробнее читайте Как разрешить ненадежным приложениям доступ к аккаунту.

Разрешить доступ ненадежных приложения к Gmail

Чтобы использовать сервис Рамблер Почта, замените в скрипте smtp.gmail.com на mail.rambler.ru. Чтобы использовать сервис Яндекс Почта, замените в скрипте smtp.gmail.com на smtp.yandex.ru. Также не забудьте изменить значения [email protected] и your_gmail_password на свои.

Настройка планировщика

Теперь нужно настроить с какой периодичностью будут создаваться резервные копии, и отправляться на email. Для этого настроим планировщик (Sheduler).

Откройте меню SystemSheduler и нажмите кнопку «плюсик», чтобы добавить новую задачу.

MikroTik: Добавить задание в планировщик

В открывшемся окне настраиваем параметры задачи:

  • в поле Name указываем имя задачи, например send_backup_to_email;
  • в поле Interval указываем с какой периодичностью будет выполняться скрипт. Мы указали интервал 24 часа. Для отладки работы планировщика укажите интервал 5 минут и текущее время Start Time. И не забудьте настроить время на MikroTik в меню System — Clock;
  • в поле On Event указываем, какую команду необходимо выполнить при запуске задачи. Мы указали команду /system script run backup_to_email, которая запускает скрипт backup_to_email;
  • нажимаем кнопку OK для сохранения задачи.

MikroTik: Настройка параметров задачи планировщика

Теперь каждый день в 00:00:00 будет создаваться резервная конфигурация MikroTik и отправляться вам на email.

Как сохранить конфигурацию MikroTik

Что бы сохранить конфигурацию MikroTik существует несколько способов и сейчас мы их рассмотрим:

Если вы ищете понятный и удобный источник информации по микротикам, то вот он: курс «Настройка оборудования MikroTik». Это видеоучебник, где «без воды» собрана вся базовая информация по работе с MikroTik и RouterOS. Для новичков станет прямым руководствам, опытные инженеры смогут освежить и упорядочить знания. 162 видеоурока и 45 лабораторных работ, основанные на программе вендора MTCNA. Первые 25 уроков можно заказать бесплатно на странице курса.

1. Самый простой способ, это воспользоваться утилитой WinBox.

Для этого откроем меню Files и нажмем Backup.

В поле Name пишем название нашей резервной копии, при желании можем зашифровать введя пароль в поле Password, если пароль не требуется, ставим галочку Don’t Encrypt и нажимаем на кнопку Backup. После этого в списке файлов появится наша резервная копия. Что бы сохранить резервную копию к себе на компьютер, перетащите файл мышкой к себе на локальный диск.

Что бы восстановить резервную копию, выбираем файл и нажимаем Restore.

Перед восстановлением сбросьте все настройки через меню System -> Reset Configuration.

2. Сохранение резервной копии через терминал.

Зайдите в терминал через меню New Terminal и введите команду:

system backup save name=Backup_term (имя можно придумать любое)

После чего появится надпись:

Saving system configuration
Configuration backup saved

и в списке файлов будет наша резервная копия

Что бы восстановить резервную копию, введите команду:

system backup load name=Backup_term

Настройки будут восстановлены из файла Backup_term

3. Сохранение настроек в текстовом формате.

Настройки вашего устройства можно сохранить так же и в текстовом формате. Это удобно если требуется сравнить 2 конфигурации или изменить какие то настройки.

Что бы сохранить настройки в текстовом формате зайдите в New Terminal и введите команду:

После выполнения команды появится в файлах сохраненная наша конфигурация

Что бы восстановить конфигурацию, введите команду:

Иногда встречаются ситуации, когда требуется сохранить только часть настроек, например настройки dhcp сервера, правила и тд, для этого существуют следующие команды:

ip address export file=ip.rsc
ip firewall mangle export file=mangle.rsc
ip firewall nat export file=nat.rsc
ip firewall filter export file=filter.rsc
queue simple export file=simple.rsc
ip dns export file=dns.rsc
files backup export file=backup.rsc
system script export file=script.rsc
system scheduler export file=scheduler.rsc
tool e-mail export file=email.rsc
ip firewall address-list export file=address-list.rsc
ip route export file=route.rsc
ip dhcp-server network export file=network.rsc
queue type export file=type.rsc
queue tree export file=tree.rsc
queue simple export file=simple.rsc
interface ethernet export file=ethernet.rsc
ip pool export file=pool.rsc
ppp profile export file=profile.rsc
log export file=log.rsc

Если вы ищете понятный и удобный источник информации по микротикам, то вот он: курс «Настройка оборудования MikroTik». Это видеоучебник, где «без воды» собрана вся базовая информация по работе с MikroTik и RouterOS. Для новичков станет прямым руководствам, опытные инженеры смогут освежить и упорядочить знания. 162 видеоурока и 45 лабораторных работ, основанные на программе вендора MTCNA. Первые 25 уроков можно заказать бесплатно на странице курса.

Как в mikrotik сохранить конфигурацию

routerboard

MikroTikLab

На всех роутерах в mikrotik сохранить конфигурацию очень просто, если у вас установлена утилита winbox для конфигурирования RouterOS то лучше всего воспользоваться ей. Открываем ее идем в раздел Files – Backup, далее задаем имя и нажимаем на кнопку «backup».

Создания бэкапа в микротик

Если хотите чтоб кроме вас этот бэкап не кто не смог восстановить и прочитать задаем пароль. После у вас создастся файл с именем которое вы задали.

Файл бэкапа

Наша команда рекомендует изучитьНаша команда рекомендует изучить углубленный курс по администрированию сетевых устройств MikroTik В курсе много лабораторных работ по итогам которых вы получите обратную связь. После обучения вы получите диплом гос. образца РФ. Подробности и доступ к началу курса бесплатно тут.

Сохранить настройки mikrotik в файл

Было глупо хранить backup только на самом миrротике, поэтому лучше его сохранить в файл на компьютер. Для этого созданный бэкап нужно просто скачать на компьютер, нажимаем правой кнопкой мыши на имя файла и выбираем download. Но есть одно, но, если вы хотите просмотреть конфигурацию при открытии этого файла текстовым редактором увидите абрукадабру. Для этого случая есть команда «export compact file=config» где «config» это имя фала которое задаётся произвольно.

Сохранение настроек микротика в файл

После ее выполнения в терминале, у вас в разделе file появится файл с именем «config» и расширением script. Его также можно скачать на компьютер и открыть блокнотом для редактирования, в нем будет все в читабельном виде.

Как восстановить микротик из бэкапа

Восстановить микротик из бэкапа так же просто, как и создать его. Если файл backup находится у вас на ПК, загрузите его в роутер после выберете его и нажмите на кнопку «Restore».

Восстановление mikrotik из backup

После восстановления перезагрузите устройство и настройки вступят в силу. Если вы хотите восстановить старый бэкап на новый роутер убедитесь, что вы знаете от него логин и пароль, так как после применения учетные данные на роутере поменяются на те которые были в файле восстановления. Для тренировки или для того, чтобы посмотреть настройки в бэкапе можете его восстановить на виртуальном роутере, да и вообще все тесты проводить лучше сначала в виртуальной среде. Как это сделать и на чем описано в статье про эмулятор eve-ng.

Вы хорошо разбираетесь в Микротиках? Или впервые недавно столкнулись с этим оборудованием и не знаете, с какой стороны к нему подступиться? В обоих случаях вы найдете для себя полезную информацию в углубленном курсе «Администрирование сетевых устройств MikroTik». В курсе много практических лабораторных работ по результату выполнения которых вы получите обратную связь. После окончания обучения вы получите диплом гос. образца РФ. Подробности и доступ к началу курса бесплатно тут.

Как сохранить конфигурацию MikroTik.

В статье расскажем, как создать резервную копию конфигурации MikroTik и восстановить конфигурацию из бэкапа.

Как сохранить конфигурацию Микротик через Winbox.

1. В левом меню Winbox или веб-интерфейсе MikroTik переходим в «Files» и в открывшемся окне «File List» нажмем кнопку «Backup«.
2. В поле «Name» окна «Backup» вводим имя резервной копии конфигурации, например file_backup.
В поле «Password» можно ввести пароль, для того, что бы конфигурация восстанавливалась только после ввода пароля из данного файла. Пароль устанавливать не обязательно.
Галочка Don’t Encrypt отключит шифрование файла с резервными настройками.
3. После заполнения всех необходимых полей нажимаем кнопку «Backup» и в окне «File List» видим новый файл формата backup с именем, который вы только что указали.
4. Что бы сохранить backup-файл микротика необходимо кликнуть на него правой кнопкой мыши и в открывшемся меня выбрать «Download».

Как восстановить конфигурацию Микротик через Winbox.

Для восстановления конфигурации Микротик из резервной копии необходимо также перейти в меню Files. В открывшемся окне «File List» выбрать резервную копию, которую хотите использовать для восстановления и нажать кнопку «Restore».
Перевод восстановлением рекомендуется сбросить все текущие настройки через меню System — Reset Configuration.

Как сохранить резервную копию Микротик через CLI или Terminal.

Для сохранения резервной копии через командный интерфейс необходимо ввести команду:

system backup save name=file_backup

где file_backup — имя файла конфигурации.

Если вы все правильно ввели, то в ответ получите сообщение:

Saving system configuration Configuration backup saved

Что бы восстановить резервную копию Микротик из терминала, необходимо ввести команду

system backup load name=file_backup

где file_backup — имя файла конфигурации.

Как сохранить конфиг Mirkotik в текстовом формате.
Предыдущие варианты не удобны, когда вам нужно посмотреть файл конфигурации в текстовом редакторе и посмотреть настройка.
Для возможности чтения файла-конфига необходимо в CLI или Terminal ввести следующую команду:

export file=file_backup.rsc"

где file_backup.rsc — имя файла конфигурации.
Далее вы можете через Winbox-File выгрузить файл-конфигурации, как это описано в начале статьи.
Для восстановления файла конфигурации в терминале введите команду:

export file=file_backup.rsc

Как сделать резервную копию определённого раздела Микротик.

Для создания резервной копии только определенного раздела переходим в сам раздел через Terminal и добавляем export file=имя_Файла:

ip address export file=ip.rsc ip firewall mangle export file=mangle.rsc ip firewall nat export file=nat.rsc ip firewall filter export file=filter.rsc queue simple export file=simple.rsc ip dns export file=dns.rsc files backup export file=backup.rsc system script export file=script.rsc system scheduler export file=scheduler.rsc tool e-mail export file=email.rsc ip firewall address-list export file=address-list.rsc ip route export file=route.rsc ip dhcp-server network export file=network.rsc queue type export file=type.rsc queue tree export file=tree.rsc queue simple export file=simple.rsc interface ethernet export file=ethernet.rsc ip pool export file=pool.rsc ppp profile export file=profile.rsc log export file=log.rsc

Восстановить только определенный раздел можно командой:

/import file=nat.rsc /import file=dns.rsc

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *